Potential Service Disruption
Incident Report for Castle Learning
Resolved
Servers had to be restarted.
Posted Jan 13, 2018 - 07:55 EST
Identified
Our automated systems have detected this condition: Site may not be accessible. We are investigating the issue and we will report back when we have more information.
Posted Jan 13, 2018 - 07:36 EST