Potential Service Disruption
Incident Report for Castle Learning
Resolved
Servers needed to be restarted.
Posted Mar 15, 2018 - 07:33 EDT
Identified
Our automated systems have detected this condition: Site may not be accessible. We are investigating the issue and we will report back when we have more information.
Posted Mar 15, 2018 - 07:31 EDT