Our security service provider CloudFlare is currently down.
Incident Report for Castle Learning
Resolved
This incident has been resolved.
Posted Jul 02, 2019 - 10:20 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 02, 2019 - 10:19 EDT
Identified
We are currently waiting for CloudFlare service to be restored. Until then our site is not accessible. Sorry for the inconvenience.
Posted Jul 02, 2019 - 09:54 EDT
This incident affected: Castle Learning Access and PrepPath Access.