Potential Service Disruption
Incident Report for Castle Learning
Resolved
No issues were found. Incident is closed.
Posted Apr 11, 2018 - 08:45 EDT
Identified
Our automated systems have detected this condition: Server Down. We are investigating the issue and we will report back when we have more information.
Posted Apr 11, 2018 - 08:42 EDT