Potential Service Disruption
Incident Report for Castle Learning
Resolved
Server OS updates caused an outage. All servers are up and running now.
Posted Apr 11, 2018 - 06:44 EDT
Identified
Our automated systems have detected this condition: Site may not be accessible. We are investigating the issue and we will report back when we have more information.
Posted Apr 11, 2018 - 06:41 EDT